Rusty
This commit is contained in:
parent
533ccbf429
commit
d6ac8cd78e
7 changed files with 126 additions and 35 deletions
|
@ -9,7 +9,7 @@ url="https://www.libressl.org/"
|
|||
license=(ISC custom:OpenSSL)
|
||||
optdepends=("ca-certificates")
|
||||
source=("https://cdn.openbsd.org/pub/OpenBSD/LibreSSL/libressl-$pkgver.tar.gz")
|
||||
sha256sums=('6d4b8d5bbb25a1f8336639e56ec5088052d43a95256697a85c4ce91323c25954')
|
||||
sha256sums=("6d4b8d5bbb25a1f8336639e56ec5088052d43a95256697a85c4ce91323c25954")
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
|
|
@ -8,13 +8,14 @@ pkgdesc="Lightweight implementation of C standard library"
|
|||
arch=("x86_64")
|
||||
url="https://musl.libc.org/"
|
||||
license=("MIT")
|
||||
depends=("nsss" "utmps")
|
||||
depends=("utmps")
|
||||
optdepends=(
|
||||
"argp-standalone: Port of argp from Glibc"
|
||||
"musl-fts: adds fts(3) functions"
|
||||
"musl-obstack: add obstack from Glibc"
|
||||
)
|
||||
backup=("etc/ld-musl-$CARCH.path")
|
||||
options=(staticlibs)
|
||||
source=(
|
||||
"https://musl.libc.org/releases/musl-$pkgver.tar.gz"
|
||||
"https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvmver/compiler-rt-$_llvmver.src.tar.xz"
|
||||
|
@ -81,6 +82,6 @@ package() {
|
|||
install -Dm0644 README "$pkgdir"/usr/share/doc/musl/README
|
||||
install -Dm0644 COPYRIGHT "$pkgdir"/usr/share/licenses/musl/COPYRIGHT
|
||||
|
||||
# utmps & nsss replacements
|
||||
rm -rf $pkgdir/usr/include/{grp,pwd,shadow,utmpx}.h
|
||||
# utmps replacement
|
||||
rm -rf $pkgdir/usr/include/utmpx.h
|
||||
}
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
# Maintainer: Daryl Ronningen <relms@relms.dev>
|
||||
|
||||
pkgname=nsss
|
||||
pkgver=0.2.0.4
|
||||
pkgrel=1
|
||||
pkgdesc="nsss is an implementation of a subset of the pwd.h, group.h and shadow.h family of functions"
|
||||
arch=("x86_64")
|
||||
url="https://skarnet.org/software/nsss/"
|
||||
license=("ISC")
|
||||
depends=("skalibs")
|
||||
source=("https://skarnet.org/software/nsss/nsss-$pkgver.tar.gz")
|
||||
sha256sums=("39b504f85bd8f6b523d334e5cfa62c02a395db35991b75f206df0abbd6761aad")
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--enable-shared \
|
||||
--enable-libc-includes
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
make DESTDIR=$pkgdir install
|
||||
}
|
34
rust/0001-Update-openssl-version-for-libresssl-3.8.2.patch
Normal file
34
rust/0001-Update-openssl-version-for-libresssl-3.8.2.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
From 7600d686efbd013a4810296a22cb87b4f08469ad Mon Sep 17 00:00:00 2001
|
||||
From: Daryl Ronningen <relms@relms.dev>
|
||||
Date: Wed, 13 Dec 2023 17:37:51 -0800
|
||||
Subject: [PATCH] Update openssl version for libresssl 3.8.2
|
||||
|
||||
---
|
||||
src/tools/cargo/Cargo.toml | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/tools/cargo/Cargo.toml b/src/tools/cargo/Cargo.toml
|
||||
index 440304416..0f3e6701f 100644
|
||||
--- a/src/tools/cargo/Cargo.toml
|
||||
+++ b/src/tools/cargo/Cargo.toml
|
||||
@@ -37,7 +37,7 @@ core-foundation = { version = "0.9.3", features = ["mac_os_10_7_support"] }
|
||||
crates-io = { version = "0.39.0", path = "crates/crates-io" }
|
||||
criterion = { version = "0.5.1", features = ["html_reports"] }
|
||||
curl = "0.4.44"
|
||||
-curl-sys = "0.4.68"
|
||||
+curl-sys = "0.4.70"
|
||||
filetime = "0.2.22"
|
||||
flate2 = { version = "1.0.27", default-features = false, features = ["zlib"] }
|
||||
git2 = "0.18.0"
|
||||
@@ -63,7 +63,7 @@ libloading = "0.8.0"
|
||||
memchr = "2.6.2"
|
||||
miow = "0.6.0"
|
||||
opener = "0.6.1"
|
||||
-openssl ="0.10.57"
|
||||
+openssl ="0.10.61"
|
||||
os_info = "3.7.0"
|
||||
pasetors = { version = "0.6.7", features = ["v3", "paserk", "std", "serde"] }
|
||||
pathdiff = "0.2"
|
||||
--
|
||||
2.43.0
|
||||
|
43
rust/PKGBUILD
Normal file
43
rust/PKGBUILD
Normal file
|
@ -0,0 +1,43 @@
|
|||
pkgname=rust
|
||||
pkgver=1.74.1
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
arch=("x86_64")
|
||||
url="https://www.rust-lang.org/"
|
||||
license=("Apache" "MIT")
|
||||
depends=("curl" "rust")
|
||||
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz" "config.toml" "0001-Update-openssl-version-for-libresssl-3.8.2.patch")
|
||||
sha256sums=(
|
||||
"67db3e22fc9921c885baae5953ba144fc474cde29ec69ab56d43ce764206231d"
|
||||
"da61598a69261649008f2a1710746574e53e159a00cc6ee8fe3a41f4f9db0227"
|
||||
"8d27a3cf137acefe1dcd9716f23c94567d7a85253a37f96b74342a677effc5dc"
|
||||
)
|
||||
|
||||
prepare() {
|
||||
cd rustc-$pkgver-src
|
||||
|
||||
cp $srcdir/config.toml .
|
||||
|
||||
patch -p1 <$srcdir/0001-Update-openssl-version-for-libresssl-3.8.2.patch
|
||||
|
||||
cd src/tools/cargo
|
||||
cargo vendor ../../../vendor/
|
||||
cargo update --recursive
|
||||
}
|
||||
|
||||
build() {
|
||||
cd rustc-$pkgver-src
|
||||
|
||||
export RUST_BACKTRACE=1
|
||||
unset RUSTFLAGS
|
||||
|
||||
DESTDIR=$srcdir/rust-build python3 ./x.py install
|
||||
}
|
||||
|
||||
package() {
|
||||
cp -r $srcdir/rust-build/* $pkgdir/
|
||||
|
||||
rm $pkgdir/usr/bin/*.old
|
||||
rm $pkgdir/usr/lib/rustlib/{components,install.log,rust-installer-version,uninstall.sh}
|
||||
rm $pkgdir/usr/lib/rustlib/manifest-*
|
||||
}
|
43
rust/config.toml
Normal file
43
rust/config.toml
Normal file
|
@ -0,0 +1,43 @@
|
|||
changelog-seen = 2
|
||||
|
||||
[llvm]
|
||||
download-ci-llvm = false
|
||||
ninja = true
|
||||
link-shared = false
|
||||
use-libcxx = true
|
||||
|
||||
[build]
|
||||
build = "x86_64-unknown-linux-musl"
|
||||
cargo = "/usr/bin/cargo"
|
||||
rustc = "/usr/bin/rustc"
|
||||
rustfmt = "/usr/bin/rustfmt"
|
||||
docs = false
|
||||
python = "python3"
|
||||
locked-deps = true
|
||||
extended = true
|
||||
|
||||
[install]
|
||||
prefix = "/usr"
|
||||
|
||||
[rust]
|
||||
optimize = 3
|
||||
debug = false
|
||||
codegen-units = 1
|
||||
codegen-units-std = 1
|
||||
incremental = false
|
||||
parallel-compiler = false
|
||||
channel = "stable"
|
||||
description = "Ikeda Linux"
|
||||
rpath = false
|
||||
codegen-backends = ["llvm"]
|
||||
deny-warnings = true
|
||||
llvm-libunwind = 'system'
|
||||
|
||||
[target.x86_64-unknown-linux-musl]
|
||||
cc = "/usr/bin/clang"
|
||||
cxx = "/usr/bin/clang++"
|
||||
ar = "/usr/bin/llvm-ar"
|
||||
ranlib = "/usr/bin/llvm-ranlib"
|
||||
linker = "/usr/bin/clang"
|
||||
llvm-config = "/usr/bin/llvm-config"
|
||||
crt-static = false
|
|
@ -19,8 +19,7 @@ build() {
|
|||
--enable-shared \
|
||||
--enabled-static \
|
||||
--libdir=/usr/lib \
|
||||
--enable-libc-includes \
|
||||
--enable-nsss
|
||||
--enable-libc-includes
|
||||
|
||||
make
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue