46 lines
923 B
Nix
46 lines
923 B
Nix
{
|
|
self,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
programs.kitty = {
|
|
enable = true;
|
|
font = {
|
|
package = self.packages.${pkgs.system}.nerd-fonts-sf-mono-ligatures;
|
|
name = "Liga SFMonoNerdFont";
|
|
size = 10;
|
|
};
|
|
settings = {
|
|
# Cursor Settings
|
|
cursor_shape = "beam";
|
|
cursor_shape_unfocused = "unchanged";
|
|
cursor_stop_blinking_after = 0;
|
|
|
|
# Scrollback Settings
|
|
scrollback_lines = 10000;
|
|
scrollback_pager_history_size = 2048;
|
|
scrollback_fill_enlarged_window = "yes";
|
|
|
|
# Mouse Settings
|
|
mouse_hide_wait = 0;
|
|
url_style = "straight";
|
|
|
|
# Bell Settings
|
|
enable_audio_bell = "no";
|
|
|
|
# Window Settings
|
|
hide_window_decorations = "yes";
|
|
|
|
# Tab Settings
|
|
tab_bar_edge = "top";
|
|
};
|
|
shellIntegration = {
|
|
enableFishIntegration = true;
|
|
};
|
|
};
|
|
|
|
catppuccin.kitty = {
|
|
enable = true;
|
|
flavor = "mocha";
|
|
};
|
|
}
|