0
0
Fork 0
flake/home/modules/cli/neovim.nix

48 lines
728 B
Nix

{
pkgs,
inputs,
...
}: {
programs.neovim = {
enable = true;
defaultEditor = true;
viAlias = true;
vimAlias = true;
vimdiffAlias = true;
withNodeJs = true;
withPython3 = true;
withRuby = true;
extraPackages = with pkgs; [
# Compilers
gcc
go
dotnet-sdk
# Rust
rustc
cargo
# Nix
nixd
inputs.alejandra.defaultPackage.${pkgs.system}
deadnix
statix
# Utils
unzip
gnumake
fd
tree-sitter
wget
imagemagick
];
extraPython3Packages = pyPkgs:
with pyPkgs; [
pip
];
extraLuaPackages = luaPkgs:
with luaPkgs; [
magick
];
};
}